Is there a canonical Assembly term for instructions or operands that are dependent on the byte offset of the instruction within the assembled/encoded output (ex: jmp
s to labels or RIP-relative operands)? Is Position-Dependent-Instruction a thing?
Is there a canonical Assembly term for instructions or operands that are dependent on the byte offset of the instruction within the assembled/encoded output (ex: jmp
s to labels or RIP-relative operands)? Is Position-Dependent-Instruction a thing?
What is the opposite of a rule-based scanner (i.e. takes an input value and returns discovered output values)? What do you call that? A value-based scanner? Is there a Wikipedia page listing the various categories/classifications of security scanners?
@wyatt I read your post and began to fear that I had misnamed my Game Boy and Game Boy Advance ports of 240p Test Suite. https://github.com/pinobatch/240p-test-mini
"#240p" means 256x240 on an #NES, 320x240 on a bunch of devices, or 400x240 on a #Nintendo3DS Top Screen. And in analog video, it even ends up including devices like #MSX and #NintendoDS that generate roughly System M timings (15.7 kHz by 60 Hz), even if the top and bottom borders are so thick that only 192 lines actually have picture. (#GameBoy and #GBA don't count as "240p" because their horizontal frequency is lower.)
Thanks for the help ref https://fediscience.org/@sbrl/113726310893898548, Fediverse !
I thought I'd do a poll of some of the suggestions.
Vote will decide the name, tho I will have the final say o/
HELP ME Fediverse !
I need a name for an open source
project I'm working on. Please suggest anything in comments! I'm kinda stumped.
It's a self-hosted AI-enhanced image search engine - see rough design sketches attached.
---------
The Plan™:
Basically it'll index all images in a given directory with 2 mechanisms:
1. Exif / meta data + filepaths
2. AI (currently CLIP) embeddings → vector DB
....then there'll be a web interface that lets you enter search terms & filter by various things like filename, exif fields, etc
Quite early in development, but got the embedding worker done today!
Aim is for it to run comfortably on a Raspberry Pi 4 that also has other things running on it.
Still to do:
- Web interface
- Exif indexer
- Quantise CLIP etc for lower resource usage, go looking for better models
- Open source the code, but need a name for the project first!
- Lotsa stuff I forget
Tech:
- Node.js (pure JS libraries where possible)
- VectorDB: https://www.npmjs.com/package/hnsw (potential issue: this is in-memory or IndexedDB)
- Exif DB: https://www.npmjs.com/package/njodb ('cause I hate working with databases 'cause they're boring - sql ESP)
- Python worker 4 embedding/AI stuff: PyTorch, CLIP
What's a more understandable name for a regular expression that matches floating point numbers in text?
What do you call the individual numbers or parts of a version number (ex: 1.2.3.beta3)?
Utopia is a documentary, exhibit 622
https://www.ato.gov.au/media-centre/mygovid-being-renamed-myid
"In mid-November 2024, the Australian Government’s Digital ID app, myGovID, will be renamed to myID."
When you refer to a UNIX/Linux/macOS/BSD or sh
/bash
/zsh
command payload, what do you common refer to them as?
and how would you group Windows PowerShell command payloads in a directory structure of other payloads?
#namingthings #payloads
How would you group Windows cmd.exe
command payloads in a directory structure of other payloads?
#namingthings #payloads
When you see $'\x68\x65\x6c\x6c\x6f'
what do you think of?
#namingthings
When you see 6c73202d6c61
what do you think of?
#namingthings
#ProgressiveWebApps (#PWAs) can act as a #shareTarget for other #apps on #Android.
https://developer.mozilla.org/en-US/docs/Web/Manifest/share_target
So when I added this feature to my app, it seemed fine to call the url `/share`.
And when I saved them to the #database I just went with it and named the table `shares`.
But here's the thing; I have my app installed on my phone too. I use the `share` feature to "post" to my website.
So, now my posts go in the `shares` table.
What is the canonical attribute name that you'd recognize for the remote IP and port that sent an HTTP request to a server. Rack and async-http have different naming conventions, and I'd like to pick the most recognizable naming convention for my Value object which represents an HTTP request.
#ruby #namingthings #http
I'm pretty sure this one needs a heroic name.
Cookie the Destroyer, that sort of thing. Ideas?
Naming things is hard. #namingThings
Is there some kind of defacto terminology for enqueueing a message into an input message queue vs. enqueueing it into an output message queue? I feel like you'd use `enqueue_mesg` for input messages and `send_mesg` for output messages.
#namingthings
What struck me was that some people didn't even agree with the thesis "if you can't come up with a name, you have a bad abstraction. If the abstraction is good, it's easy to come up with a name." Here I came across an article just about this thesis, I recommend reading it to those who have difficulties in naming.
(2/2)
https://www.ben-morris.com/naming-things-is-easy-abstraction-is-much-harder/